Dataflow Compiler (DFC) Availability!

Dear Hailo community!

We’ve heard your feedback, and we’re excited to announce that access to the Dataflow Compiler (DFC) is now available!

With that, we would like to help you set the right approach towards using the DFC.

Bring Your Own Data (BYOD) - The most recommended way is using the retraining Docker containers from the Hailo Model Zoo. This will allow you to use some of the most popular networks, (re)trained on your own custom data (see this link for an end-to-end example in our GitHub repo).

Bring Your Own Model (BYOM) – This method requires a deeper understanding of the model and the conversion flow from ONNX or TensorFlow Lite (TFLite) to Hailo’s HEF format. We suggest using the DFC user guide and tutorials. This approach may present more challenges compared to using the retraining Docker containers from the Model Zoo, but for some, the ride is as enjoyable as the destination :blush: (see this link for DFC tutorials).

Large models (e.g., LLMs, Whisper, Stable-Diffusion, etc.) include some of the SoTA models and are naturally very attractive. We’re actively working on enabling the porting of these models to Hailo, but at this point in time, we cannot yet execute these on the Hailo-8L.

Please bear with us as we embark on this adventure of releasing the DFC. We are committed to giving the best experience that we can deliver, and we believe this is another step in enabling exciting projects :blush:


Cant find the download link for the compiler, does not go anymore to the page where compiler could be downloaded. Furthermore, documentation for manual installation of compiler also points to, see

Hey @alexander ,

In the software download, you have to choose the following :

You will see the DFC and the documentation for installing it.


What i am trying to say is that you do not get to that page trying with the above addresses. They are both going to the new page and not to the download page.

I’m new here, but I believe you have to log in to dev zone in order to see it. It appears that your community login will work. But, they do appear to be logged in separately. I see it fine.

Really strange. I am logged in, and use same creds as here. When I try to get to, or, I end up at - looks like this.

Very strange. I clicked on the links that you provided and it took me straight to it. I’m even on a different computer now and had to log in. But, took me right there after I did. I’m at a loss…

One thought… have you tried clearing your browser cache and clicking on the link again?

Seems to be fixed, see the software now

hi all, it still not fix link, I try click “SW Download” button, but it straight to

Hey @thanhithcmus

Please clear the cache of the browser and re-try .


Is the DFC only available for x86_64 or is it available for arm64 as well?

Hey @mike1 ,

Welcome to the Hailo Community!

The DFC is only available for x86.

Best regards

how to install for raspberry pi

Hello @basuroyrohan,

The DFC is only available on x86 machines because it is a compiler used to create models, but it does not actually run the models. On Raspberry Pi devices, we only run the pre-compiled models and use them, we do not use the DFC compiler itself on the RPi.

Best regards,

Hello, can I install the DFC add-on python library and make the conversation of onnx files to .hef in windows operational system?

Hey All, I’m using Hailo8L hardware. I’ve trained my dataset. Now, I’m facing challenge on converting pt file to hef. Please help me here


1 Like

Have the same problem too

1 Like